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The latest support and technical information is available at: 
http://www.realaudio.com/help.html
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 Introduction
Welcome to the RealAudio Player 3.0 by Progressive Networks. The RealAudio system is 
the premier real-time audio delivery system for the Internet. 
Using RealAudio Player, you can listen to thousands of hours of live and pre-recorded clips,
including sporting events, live radio stations, news, music, and lectures. In addition, 
RealAudio Player includes several different RealAudio Player components and provides 
access to a customized Timecast World Wide Web site.
For more information, refer to our web site http://www.realaudio.com

See Also:
New Features 
RealAudio Players 
Using RealAudio Player 
Troubleshooting 



 New Features
New features in RealAudio Player 3.0:

· New Codecs - Eight new encoding algorithms, including several for connections 
faster than 28.8 Kbps connections. In addition, there are now multiple codecs at the 
each bandwidth to provide the best possible sound quality for the specific content 
type.

· Stereo Sound - This is the first time any company has offered stereo sound for 28.8 
Kbps modems. In addition, near CD quality sound can be delivered for ISDN and LAN 
connections.

· Robust UDP - Improves sound quality by improving communication between 
RealAudio Player and RealAudio Server.

· Java-enabled Plug-in - The Java-enabled Plug-in provides access to RealAudio 
programming within Java environments and extends the audio capabilities of your 
browser.

· HTTP Streaming - Allows casual audio content providers to stream RealAudio 
sound. While this method is not as robust, it provides a reasonable method for 
providing RealAudio content.



 RealAudio Players Components
In addition to RealAudio Player, four different special-purpose RealAudio Player 
components are installed on your computer. The components work with different elements 
within World Wide Web pages to deliver RealAudio sound in a variety of ways. The 
RealAudio Player components are:

RealAudio Plug-in The Plug-in provides access to RealAudio 
programming and extends the audio 
capabilities of your Netscape browser 
(Netscape Navigator 2.0 or later). 

RealAudio Control for 
ActiveX

The Control provides access to RealAudio 
programming and extends the audio 
capabilities of your Internet Explorer 3.0 
browser and Visual Basic applications.

RealAudio Xtra for 
Shockwave

The RealAudio Xtra for Shockwave provides 
RealAudio programming within a Macromedia 
Shockwave movie.

Java-enabled Plug-in The Java-enabled Plug-in provides access to 
RealAudio programming within Java 
environments and extends the audio 
capabilities of your browser.

 Overview of RealAudio Player
The RealAudio Player enables you to listen to RealAudio files over the Internet or over a 
local area network in real-time, without downloading the sound clip to your hard drive. 
When you click on a RealAudio link from a World Wide Web page, your RealAudio Player 
automatically opens and plays the file you have selected.

Overview of RealAudio Player

Section Description
Play/Pause Button This button plays or pauses a clip depending 

on the status of the clip. 



Stop Button
Click the  button to stop the clip. 

Fast Forward/Rewind 
Buttons

Click either the  button or the  button to 
fast forward or rewind the RealAudio clip in 10
second intervals.

Position Slider The slider moves as a clip is being played. You
can fast forward or rewind to a different 
section of the audio clip by dragging the 
slider.

Link to the Progressive 
Networks Home Page

If you are connected to the Internet, click this 
button to link to the Progressive Networks 
Home Page - the Home of RealAudio. The icon 
displayed changes depending on the action of
RealAudio Player. The following are the icons 
that can be displayed and their meanings:

(Spinning)
Indicates that RealAudio Player is contacting a
RealAudio Server.

Indicates that RealAudio Player is playing an 
audio stream.
Indicates moderate packet loss, sound quality 
similar to AM radio transmission.
Indicates high packet loss, sound quality 
below AM radio transmission (garbled or 
choppy speech, skipping).

Title, Author and 
Copyright Text

The Content provider specifies the text in 
these fields; they normally describe the clip 
being played.

Volume Control The volume control indicates the volume at 
which the clip is being played. You can 
increase the volume by dragging the control 
up, and decrease the volume by dragging the 
control down.

Status Bar The status bar displays the current action of 
the Player. For example: Buffering, Playing
28.8 Network Stream, or Paused.

Stereo Indicator This graphic indicates whether the clip 
currently being played is mono or stereo.

 - Indicates that the clip being played is 
stereo.

 - Indicates that the clip being played is 
mono.

Elapsed Time The Elapsed Time is the length of time that 
the clip has been playing.

Total Time The Total Time is the length of the entire clip.



Note: When playing a live stream, the Total 
Time value is 00:00.0.

See Also:
RealAudio Player Menus 
Using RealAudio Player 
Troubleshooting 



 RealAudio Player Menus
The RealAudio Player has five menus: File, View, Clip, Sites, and Help. These menus allow 
you to take full advantage of RealAudio Player features.

See Also:

File Menu 
View Menu 
Clip Menu 
Sites Menu 
Help Menu 



 File Menu
Commands from the File menu allow you to play RealAudio files without using your World 
Wide Web browser to find files on the Internet, and to exit RealAudio Player. 

Menu Option Description
Open Location Select this option to play RealAudio files 

through the Internet without using your World
Wide Web browser. In the Open Location 
dialog, enter the URL (Internet address) of 
a .ra or .ram file.

Open File Select this option to play a local RealAudio 
file. When the Open File dialog appears, 
select a .ra or .ram file stored on your 
computer.

Open Recent Select this option to view a list of recently 
played clips. You can select a clip from this 
list to hear the clip again.

Exit Select this option to exit RealAudio Player.

 View Menu
Commands from the View menu allow you to control the appearance, to customize the 
operation, and view the performance of RealAudio Player.

Menu Option Description
Info & Volume Select this option to display the volume 

control, and the title, author, and copyright 
information for the clip; a check mark 
appears next to the option. Select the option 
again to hide the information; the check mark
is removed. 

Status Bar Select this option to display the Status Bar; a 
check mark appears next to the option. 
Select the option again to hide the bar; the 
check mark is removed. 

Refer to Messages for a list of messages that 
appear in the Status Bar

Preferences Select this option to display the Preferences 
window for configuring RealAudio Player. You 
can set preferences from this window. Refer 
to Setting Preferences for more information.

Statistics Select this option to display the transmission 
quality information in the Connection 
Statistics dialog. The Connection Statistics 
window reports the performance of the 



Internet connection between the RealAudio 
Server and RealAudio Player.

Always on Top Select this option to make RealAudio Player 
remain on top of all other windows, even 
when another window is active; a check mark
appears next to the option. Always on Top is 
convenient for keeping RealAudio Player 
visible while you interact with your World 
Wide Web browser. Select this option again to
allow other windows to open on top of 
RealAudio Player; the check mark is removed.

 Messages
Buffering - Indicates that the Player has connected with a RealAudio server and is 
collecting the audio stream in the buffer (holding area) until enough packets arrive to start 
playing the audio stream. This takes only a few seconds.

Note: If PerfectPlay Mode is enabled, the amount of the audio stream that is buffered 
before playing is increased.

Stopped - Indicates the audio has stopped, because you selected the stop button or 
because the end of the clip has been reached.

Paused - Indicates the audio has stopped because you selected the Pause button.

(Clip 1 of 2) - Indicates that the first clip of a multi-clip stream is being played.

Playing xx.x local file - Indicates the algorithm with which the local RealAudio file was 
encoded.

Playing xx.x network stream - Indicates the algorithm with which the network 
RealAudio file was encoded.

Playing xx.x live stream - Indicates the algorithm with which the live RealAudio file is 
being encoded.

Contacting Host - Indicates that the Player is requesting a file from a RealAudio Server.



 Clip Menu
Some RealAudio clips are several files played one after the other. Commands from the Clip 
menu allow you to move between clips in a multi-clip RealAudio (.ram) file. They are 
similar to the seek buttons on a CD player. If there is only one RealAudio clip at the link 
you are accessing, these options are not available.
Previous Clip and Next Clip are also available from the shortcut menu that appears when 
you right-click the mouse button in RealAudio Player window.

Menu Option Description
Previous Clip Select this option to play the previous clip in 

a multi-clip RealAudio (.ram) file.

Next Clip Select this option to play the next clip in a 
multi-clip RealAudio (.ram) file.

 Sites Menu
Commands from the Site menu allow you to access various pages at the Progressive 
Networks and Timecast World Wide Web sites. This feature works with popular World Wide 
Web browsers including Netscape Navigator, Internet Explorer, Mosaic, Spyglass Mosaic, 
and Spry Mosaic. If you are connected to the Internet, and your World Wide Web browser is
not open, RealAudio Player opens it for you.
Note: You must be connected to the Internet in order to reach these sites.

Menu Option Description
RealAudio Home Page Select this option to access the Progressive 

Networks Home Page.
Timecast: The 
RealAudio Guide

Select this option to access Timecast: the 
RealAudio Guide. Timecast contains a list of 
World Wide Web sites providing RealAudio 
content.

RealAudio Help Page Select this option to access the RealAudio 
main help page.

 Help Menu
Commands from the Help menu provide you with online help and information about 
RealAudio Player.
The latest support and technical information is available at: 

http://www.realaudio.com/help.html



Menu Option Description
Contents Select this option to open this online help for 

RealAudio Player.

About Select this option to display RealAudio Player 
version and Copyright information.

 Using RealAudio Player
The RealAudio Player enables you to click on a RealAudio link from your Web browser and 
begin playing audio instantly, without download delays. In addition, you can pause, rewind,
fast-forward, stop, and start the audio at a click of a button.
See Also:

Starting a Clip 
Pausing a Clip 
Stopping a Clip 



 Starting a Clip
There are several ways to start a RealAudio clip:

· Click a RealAudio link on a World Wide Web page. Your World Wide Web browser 
opens RealAudio Player and the audio is streamed to RealAudio Player immediately. 
After storing a few seconds of audio (buffering), the clip begins.

· Access a World Wide Web site or select an action that automatically plays a clip. Your 
World Wide Web browser opens RealAudio Player and the audio is streamed to 
RealAudio Player immediately. After storing a few seconds of audio (buffering), the 
clip begins.

· Click Open File or Open Location on the File menu on RealAudio Player. For more 
information, refer to File Menu.

See Also:

Pausing a Clip 
Stopping a Clip 



 Pausing a Clip

You can pause a clip while it is playing by clicking the  button. This halts the 
audio stream. If you want to resume the clip at the same point it was paused, click the 

 button.
If you pause a clip but do not resume playing after several minutes, the RealAudio Server 
may terminate your connection. The length of time you can pause a clip without your 
connection terminating depends on the particular RealAudio Server.

See Also:

Starting a Clip 
Stopping a Clip 



 Stopping a Clip

You can stop a clip while it is playing by clicking the  button. The clip stops playing. To 
play the clip again from the beginning, click the 

 button.
See Also:

Starting a Clip 
Pausing a Clip 



 Setting Preferences
You can customize RealAudio Player by changing the settings in the Preferences window. 
The Preferences control various aspects of RealAudio Player functionality such as the 
number of clips to remember, network information, and proxy information.

See Also:

General Preferences 

Connection Preferences 
Transport Preferences 

Proxy Preferences 
Advanced Preferences 

Language Preferences 



 General Preferences
The General tab in the Preferences window contains preferences for number of clips saved 
on the Open Recent menu, and Synchronized Multimedia support. 

Field Description
Open Recent You can quickly replay clips by clicking Open 

Recent on the File menu. This setting controls 
how many clips are displayed in the Open 
Recent menu.

Synchronized 
Multimedia

Some RealAudio clips contain synchronized 
multimedia events that display pages or 
images in your web browser. This setting 
controls whether RealAudio applications 
enable these events.

 Connection Preferences
The Connection tab in the Preferences window contains information about your bandwidth,
statistics, and server timeout.

Field Description
Bandwidth RealAudio applications automatically select 

which content can be delivered in real-time 
over your connection. This setting controls the 
bandwidth of the content selected.

Statistics RealAudio applications maintain statistics on 
connection quality. These statistics help 
content providers improve the quality of their 
service. This setting controls whether statistics
are sent to the content provider.
Note: RealAudio Player does not send the 
content provider any information about your 
identity (your user name or e-mail address).

Network Timeout This setting controls how long RealAudio 
applications wait to receive data before 
considering a network connection to have 
failed. Increase this value if you frequently 
receive timeout errors.

 Transport Preferences
The Transport tab in the Preferences window allows you to customize your network 
connection for RealAudio Player.



The descriptions of these preferences assume a basic knowledge of Internet protocols and 
firewalls. For more information about firewalls, refer to our World Wide Web site at 
http://www.realaudio.com/firewall.html.

Field Description
Network Transport RealAudio clips can be transmitted to your 

computer via several different network 
transports. This setting controls how these 
network transports are selected.

Automatically select 
most efficient transport

Use this setting if you are not aware of any 
problems that require you to specify a 
transport method.

Use specified transports Use this setting if your computer has 
problems using some network transports. 
(Consult your network administrator for the 
appropriate setting.)

Click the Change Settings button to access 
the Network Transport Settings window. Refer
to 

UDP Port Some networks have limited ports available 
for Internet applications. This setting controls 
which port RealAudio applications use for 
receiving data. (Consult your network 
administrator for the appropriate setting.)

Note: This setting does not affect TCP 
packets which can only be received through 
Port 7070.

 Specify Transports Window
The Network Transport Settings window allows you to select the different modes of 
network transports that you can receive. (Consult your network administrator for the 
appropriate setting.)



 Proxy Preferences
A proxy is a server that acts as an intermediary between a company's protected LAN and 
the Internet. The proxy server insures that all data transmission between the Internet and 
a user on the LAN is authorized. RealAudio Player can be configured to work with proxy 
servers by setting the proxy preferences. If you set the Proxy preferences, you must enter 
a RealAudio Proxy and a HTTP Proxy.

For more information about proxies and firewalls, read 
http://www.realaudio.com/firewall.html. 

Field Description
Use Proxy Click this box if RealAudio applications should 

connect to the Server using a proxy; a check 
mark appears in the field. Otherwise, do not 
click this box.
Note: If you are behind a firewall and do not 
know the host name or port number of your 
proxy server, ask your firewall administrator.

RealAudio Proxy Enter the domain name or IP address of the 
RealAudio proxy server and port number that 
RealAudio applications should use to 
communicate with the proxy server. 

Note: For information on RealAudio Proxy, 
read http://www.realaudio.com/firewall.html

HTTP Proxy Enter the domain name or IP address of the 
HTTP proxy server and port number that 
RealAudio applications should use to 
communicate with the proxy server. Check 
your World Wide Web browsers proxy 
configuration.

No Proxy for: [Host 1, 
Host2]

If you have specified that RealAudio 
applications should be connected to the 
Server using a proxy, you can specify certain 
local hosts (domain names or IP Addresses) 
with which you do not need to communicate 
using the proxy server. Enter these hosts in 
this field. This field is only available if you 
have enabled the Use Proxy option.

Your firewall administrator can provide you 
with this information, if appropriate.

 Advanced Preferences
Options on the Advanced tab of the Preferences window override RealAudio Player defaults
for sound card compatibility. You dont need these options unless you are having troubles 



with sound quality.

Field Description
Disable 16-bit sound 
(use 8-bit only)

Use this setting if you have an older sound 
card and clips sound scratchy or distorted.

Disable custom 
sampling rates 

Use this setting if clips play at wrong speed or 
sound scratchy or distorted. (Requires a 
floating point coprocessor.)

Playback Performance RealAudio applications use this setting to 
optimize the performance of audio playback. 
Change this setting only if your computer 
seems sluggish or has problems while playing 
some audio content.

 Language Preferences
The setting on the Language tab of the Preferences window determines the language used 
within the RealAudio Player applications.

Field Description
Current Language This field displays the language being used 

within RealAudio applications.
Installed Languages Select the language you want to use within 

RealAudio applications.
Note: Please contact Progressive Networks 
regarding information on languages available 
for RealAudio applications.

 Troubleshooting
For the latest information on RealAudio products, visit the Progressive Networks home 
page at:

http://www.realaudio.com

A technical knowledge base, frequently asked questions list and technical library are 
available from our web site at:

http://www.realaudio.com/help.html

See Also:

How do I configure my browser to support RealAudio?  
What's wrong when the sound is poor?  

Why doesn't my RealAudio Player have a Volume Control slider?  



What causes RealAudio clips to occasionally skip?  

Why can't I play RealAudio clips on my computer at work?  



 How do I configure my browser to support RealAudio?
With most browsers, RealAudio Player installation configures the browser to support 
RealAudio. If you change your browser and it stops recognizing RealAudio files, reinstall 
RealAudio Player. 

To manually configure your World Wide Web browser:

1. Open the Options or Preferences or Settings menu. 

2. Select the Helper Applications or similar option. 
3. Look for "audio/x-pn-realaudio" in the File type list. If an entry exists, select the entry. 

Otherwise, click New Type. Enter audio as the Mime Type. Enter xpnrealaudio as 
the Mime SubType. Click OK. 

4. Enter ra,ram in the Extensions field. 
5. Select the Launch Application option. Browse and find the directory in which 

RealAudio Player is installed. 
6. Select RealAudio (raplayer.exe) as the application to launch.



 What's wrong when the sound is poor?
The sound quality should be similar to FM mono. If the sound quality is below AM radio 
transmission (garbled or choppy speech, skipping, etc.), use the following to isolate and 
correct the problem. If the audio quality was poor when the "Setup is Complete" file was 
played (during RealAudio Player installation), try configuring RealAudio Player or your 
sound card. 

If the audio quality was poor from a particular site, use the Connection Statistics window in
RealAudio Player to check for lost packets. If the packet loss is high, it may be due to a 
busy network. Connect to the site at a later time. 
If the audio quality is poor on every site, do the following: 

1. Check the actual modem connection speed. This may be shown in the lighted display 
for external modems, or through an information window if you have an internal 
modem (check the user manual for your modem). Sometimes service providers use a
lower rate connection speed such as 14.4, so even though you are dialing in on a 
28.8 modem, you are only receiving data at 14.4 Kbps. 

2. For a 14.4 connection on an Apple Duo, go to the modem properties window and turn 
off the compression control. Compression uses CPU cycles that RealAudio Player may 
need. Since RealAudio files are already compressed, this utility is not necessary. 
Turning off compression will not affect your computer's other operations. 

3. If you are using an external modem with a Windows PC and the Connections Statistics
window shows minimal packet loss (10% or less), there may be a problem with the 
speed at which packets are transferred between the modem and serial card. Try 
setting the port speed higher (at least twice the modem speed).



 Why doesn't my RealAudio Player have a Volume Control slider?
Be sure a check mark appears next to the Info & Volume command on the View menu. If 
the check mark does not appear, select the Info & Volume option.
If the sound card installed in your computer does not support volume control, the Volume 
Control slider does not appear on RealAudio Player.



 What causes RealAudio clips to occasionally skip?
Starting or quitting large applications while playing RealAudio can cause a brief disruption 
of the playback. 



 Why can't I play RealAudio clips on my computer at work? 
If you're on a local area network which is attached to the Internet, and are unable to play 
RealAudio files from remote Web sites, it's possible that your company's firewall is 
preventing the RealAudio stream from reaching you. Users can receive live and on-demand
audio from the Internet without exposing their company's network to security risks.
If your computer is behind a firewall, please see Progressive Networks firewall page for 
more information: http://www.realaudio.com/firewall.html



Play/Pause Button
This button plays or pauses a clip depending on the status of the clip.



Stop Button

Click the  button to stop the clip. 



Fast Forward/Rewind Buttons

Click either the  button or the 

 button to fast forward or rewind the RealAudio clip in 10 second intervals.



Position Slider
The slider moves as a clip is being played. You can fast forward or rewind to a different 
section of the audio clip by dragging the slider.



Link to the Progressive Networks Home Page
If you are connected to the Internet, click this button to link to the Progressive Networks 
Home Page - the Home of RealAudio. The icon displayed changes depending on the action 
of RealAudio Player.



Volume Control
The volume control indicates the volume at which the clip is being played. You can 
increase the volume by dragging the control up, and decrease the volume by dragging the 
control down.



Status Bar
The status bar displays the current action of RealAudio Player. For example: Buffering, 
Playing 28.8 Network Stream, or Paused.



Elapsed Time/Total Time
The Elapsed Time is the length of time that the clip has been playing and the Total Time is 
the length of the entire clip.

Note: When playing a live stream, the Total Time value is 00:00.0.



Stereo Indicator
This graphic indicates whether the clip currently being played is mono or stereo.

 - Indicates that the clip being played is stereo.

 - Indicates that the clip being played is mono.



Title, Author and Copyright Text
The content provider specifies the text in these fields; they normally describe the clip 
being played.



File
Commands from the File menu allow you to play RealAudio files without using your Web 
browser to find files on the Internet, to record RealAudio files, and to exit RealAudio Player. 



View
Commands from the View menu allow you to control the appearance, to customize the 
operation, and view the performance of RealAudio Player.



Clip
Commands from the Clip menu allow you to move between clips in a multi-clip RealAudio 
(.ram) file. They are similar to the seek buttons on a CD player. If there is only one 
RealAudio clip at the link you are accessing, these options are not available.
Previous Clip and Next Clip are also available from the shortcut menu that appears when 
you click the right mouse button anywhere in RealAudio Player window.



Sites
Commands from the Site menu allow you to access various pages at the Progressive 
Networks and Timecast World Wide Web sites. This feature works with popular World Wide 
Web browsers including Netscape, Internet Explorer, Mosaic, Spyglass Mosaic, and Spry 
Mosaic. If you are connected to the Internet, and your World Wide Web browser is not 
open, RealAudio Player opens it for you.
Note: You must be connected to the Internet in order to reach these sites.



Help
Commands from the Help menu provide you with online help and information about 
RealAudio Player.




